Problem: You are given an array, you have to find the closest integer to its average, look it has to be closest,not just the truncated version of the average.
Input: First line contains n , number of elements of array, next line contains n integer separated by a space, which are elements of the array.
Output: Print output according to given condition.See Sample output.
Constraints: 1≤n≤100
1≤ element of array ≤ 1000
Sample Input: 2
10 15
Sample Output:
12
n = int(input())
a = sum(map(int, input().split())) / n
print(int(a) + 1 if a % 1 > 0.5 else int(a))
Congratulations @lochard! You have completed the following achievement on the Hive blockchain And have been rewarded with New badge(s)
Your next target is to reach 100 posts.
You can view your badges on your board and compare yourself to others in the Ranking
If you no longer want to receive notifications, reply to this comment with the word
STOP
To support your work, I also upvoted your post!
Check out our last posts: