Dcoder Admiration @ Dcoder

in #programminglast year

Problem: Dcoder has N members each numbered from 1 to N. A member admires other member if its number divides the other member's number.

Given a number N you need to find the number of people with odd number of admirers

Input: T the number of test cases.
For each test case an integer N
Output: A single integer representing the number of members with odd admirers.
Constraints: 1 < T < 100
1 < N < 10^9
Sample Input: 1
5
Sample Output:
3

for i in range( int( input() ) ):
    n = int( input() )
    print( n - int( pow( n, 0.5 ) ) )